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1
Introduction
Welcome to CodeWarrior Constructor for Palm OS® software. Con-
structor is used to build a visual interface for Palm OS software ap-
plications, used by devices like Palm™ connected organizers. 

Introduction Overview
To learn about using CodeWarrior Constructor for Palm OS

 
soft-

ware:

• Read the Release Notes. The release notes provide important 
information about last-minute changes to Constructor for 
Palm OS software. 

• What’s New. Includes additions and changes to this manual.

• System Requirements. Provides information about the hard-
ware and software you need to use Constructor for Palm OS 
software.

• Starting Points. Provides an overview of the chapters in this 
manual.

• Where to Learn More. Provides additional resources for 
learning and using CodeWarrior tools. 

Read the Release Notes
Before using Constructor, read the Constructor release notes in the 
CW Release Notes folder for important information about new fea-
tures, bug fixes, and last-minute changes not included in this docu-
mentation. 
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Introduction
What’s New
What’s New
This manual has been updated to describe CodeWarrior Construc-
tor for Palm OS version 1.5. In addition, this manual provides infor-
mation about new resources for use in the Palm OS 3.5 software. 

New features in this version of the software include: 

• A Default App Category option lets you assign an applica-
tion to a default category when it is installed on a device. 
This option is available in the Project settings section of the 
Project window. This optioin specifies a default application 
category for an application when it is installed on a device. 
Resulting file type is tAIC. If you do not make an entry in the 
Default App Category field, the application is assigned to the 
Main application category by default.

• The Generate App Resources option option is now turned off 
by default in the Project settings window. When selected, this 
option instructs Constructor for Palm OS software to include 
a version resource ('tver') and an application icon name re-
source ('tAIC') in the project’s resources.

• A Bitmap Families resource (tbmf ), used as a container ele-
ment for up to four bitmaps rendered at different bit depths, 
has been added to the Project window resource list. 

• An Application Icon Families resource (tAIF), used as a con-
tainer element for up to four icons rendered at different bit 
depths, has been added to the Project window resource list. 

• New user interface objects, including a graphic button, 
graphic pushbutton, graphic repeating button, slider control, 
and feedback slider control, have been added. 

System Requirements
If you currently use other CodeWarrior software, you can use Con-
structor for Palm OS software.

• Windows Requirements

• Mac OS Requirements
CNP–10 Constructor for Palm OS 



Introduction
System Requirements
Windows Requirements

Table 1.1 describes hardware and software requirements for using 
Constructor on Microsoft Windows.

Table 1.1 Microsoft Windows requirements

Mac OS Requirements

Table 1.2 lists hardware and software requirements for using Con-
structor on a Macintosh OS computer.

Table 1.2 Mac OS requirements

Constructor for Palm OS software is part of a complete package that 
includes the CodeWarrior IDE and other Palm OS software devel-
opment tools. Note that you need all of these elements to use Con-
structor for Palm OS effectively.

Hardware Palm connected organizer with HotSync® cra-
dle (optional, but recommended); Intel Pen-
tium-class processor (recommended) or 80486-
class processor; 24 megabytes of RAM; CD-
ROM drive; 90 MB free hard disk space.

Software CodeWarrior for Palm OS software; Windows 
NT 4.0 or higher (recommended); Windows 95 
or higher.

Hardware Palm connected organizer with HotSync cradle 
(optional but recommended); PowerPC (recom-
mended) or MC68040 processor; 24 megabytes of 
RAM (32 megabytes recommended); a CD-ROM 
drive, 90 megabytes free hard disk space.

Software CodeWarrior for Palm OS software, Macintosh 
System 7.5.3 or higher; 68K-based Macintosh com-
puters require CFM 68K Enabler 4.0 (provided by 
the CodeWarrior installation software for system 
software before Macintosh operating system 8).
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Introduction
Starting Points
Starting Points
Topics for new Constructor users

If you have not used Constructor before, see the Constructor Funda-
mentals Overview for an overview of Constructor for Palm OS ap-
plications.

Topics for experienced Constructor users

If you’ve already used other Constructor for other operating sys-
tems or frameworks, refer to these topics to find out how to use 
Constructor for Palm OS:

• Working with Forms, for information about how to create 
and edit forms, including dialog boxes and about boxes.

• Working with Menu Bars and Menus Overview, for informa-
tion about how to create and edit menu bars and menus.

• Working with Character Strings Overview, for information 
about how to create and edit character strings and help text. 

• Working With Alerts Overview, for information about how 
to create and edit alert boxes. 

• Working With Icons & Bitmaps Overview, for information 
about how to create and edit icons, icon families, bitmaps, 
and bitmap families. 

• Constructor Menu Reference Overview, for descriptions of 
menus and menu items in the Constructor for Palm OS appli-
cation.

Where to Learn More
To learn about using other CodeWarrior tools for Palm OS software 
development, see the Targeting Palm OS documentation and the 
documentation provided by Palm Computing.
CNP–12 Constructor for Palm OS 



2
Constructor 
Fundamentals
This chapter introduces you to and provides a high-level overview 
of Constructor for Palm OS® software. 

Constructor Fundamentals Overview 
Constructor is a visual resource editor used to specify how your ap-
plication appears to the end user. Using Constructor, you create and 
edit several types of resources for Palm OS software applications. 

The following topics are included in this chapter:

• What is a Palm OS Resource? defines resources and how they 
are used in a Palm OS software application. 

• Constructor’s Resource Types identifies the resource types 
you can create and edit using Constructor. 

• Constructor Project Files files are used to hold the resources 
you create and edit using Constructor. 

• Source Code Generation is used to create C preprocessor def-
initions to refer to resources you have created with Construc-
tor.

• Project Window defines the display window for a project file. 

• Editor Windows display the relationship between individual 
resource editors and the Project window. 

• Property Inspector Window is a generic display for resource 
properties. 

• User Interface Features provides a quick look at the Con-
structor user interface. 
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Constructor Fundamentals
What is a Palm OS Resource?
What is a Palm OS Resource?
A Palm OS software resource is a data structure that describes the 
characteristics of user interface element, for example, a form, a dia-
log box, or a string of text. 

A Palm OS software application uses resources to present some-
thing to the user. For example, a database application for Palm OS 
software might have one form for entering and editing records, and 
another form for displaying a list of records. Each form is stored in 
the application as a form resource, which contains a description of 
the buttons, text fields, and other elements that make up the form. 
In addition, the same database application may use other resources 
to store help text, a default list of category names for the database, 
bitmap pictures, and an application icon.

Constructor’s Resource Types
Constructor manages these types of resources for Palm OS software:

• Application Resources

• Forms and Controls

• Menus

• Character Strings, String Lists, and Category Names

• Alerts

• Icons and Bitmaps

Application Resources

Constructor optionally creates version (a resource of type 'tver') 
and application icon category (a resource of type 'tAIC') resources 
that Palm OS uses to display information about your application. 
See “Generate App Resources option” for more information.
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Forms and Controls

A typical Palm OS software application has one or more forms. A 
form is a window that contains user interface controls that can only 
be displayed in a form. These user interface controls are also stored 
as resources to which a form resource refers. Constructor creates 
these control resources when you add them to a form.

You use Constructor to create, design, and modify form resources (a 
resource of type 'tFRM') interactively in a WYSIWYG (What You 
See Is What You Get) environment. Constructor displays your 
forms almost exactly as they will appear on an actual Palm OS de-
vice.

For more information about working with forms, see “Working 
with Forms Overview.”

Menus

A Palm OS application often uses a menu bar with menus. Menu 
bars and menus are displayed across the top of the Palm organizer 
when you tap the Menus icon on the Palm organizer screen. You use 
Constructor to create and edit menu bar and menu resources. 

Palm OS uses two menu-related resources: a menu bar resource (a 
resource of type 'MBAR'), and menu resources (a resource of type 
'MENU') attached to a menu bar.

For more information about working with menu bars and menus, 
see “Working with Menu Bars and Menus Overview.”

Character Strings, String Lists, and Category 
Names

This topic describes the character string resources that you may cre-
ate and edit with Constructor. For more information about working 
with character strings, string lists, and app info string lists, see 
“Working with Character Strings Overview.”
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Character string resource

A character string resource (a resource of type 'tSTR') holds a 
character string. Use a character string resource to hold a piece of 
text like a non-editable text caption in a form or help text.

Use Constructor’s string editor to create and edit character string re-
sources.

Character string list resource

A character string list resource (a resource of type 'tSTL') holds a 
group of character strings. Use a string list resource to hold a group 
of related strings like country names for a list in a form. To access a 
string within a string list resource, use the SysStringByIndex() 
routine in Palm OS.

Use Constructor’s string list editor to create and edit character 
string list resources.

Category name list resource

An app info string list resource (a resource of type 'tAIS') holds a 
group of default category names for a database. Use this resource 
when calling CategoryInitialize().

Use Constructor’s app info string list editor to create and edit app 
info resources.

Alerts

A Palm OS application uses an alert box to display information that 
the user must address immediately. An alert is a modal dialog box 
with an icon, text, and one or more buttons.

Use Constructor to create and manage alert resources ('Talt').

For more information about working with alerts, see “Working 
With Alerts Overview.”
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Icons and Bitmaps

Icons and bitmap images are often used in Palm OS software appli-
cations. You use Constructor’s bitmap tools to draw and manage 
regular (black and white) icons ('ICON'), multi-bit (4-level gray-
scale) icons ('cicn'), and black and white and 4-level grayscale bit-
map images ('PICT') resources.

NOTE: Multi-bit icons and grayscale bitmaps are only supported 
in Palm OS 3.0 and later. 

For more information about working with icons and bitmaps, see 
“Working With Icons & Bitmaps Overview.”

Constructor Project Files
This section discusses how Constructor stores information in files, 
and how to work with those files, including:

• Managing Files with Constructor

• Understanding the Resource.frk folder

• Moving a Constructor File Between Platforms

Managing Files with Constructor

Constructor works on resources within Constructor project files. To 
incorporate your resources into a Palm OS application, you add 
your Constructor project file to the project file you created in the 
CodeWarrior IDE.

Constructor recognizes and edits many (but not all) resource types 
used in Palm OS software development. Non-Constructor resource 
types are retained in the project file but ignored by Constructor. 
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Table 2.1 Managing a Constructor project file

The ability to save changes is affected by the status of the file. If a 
file is locked or read-only, you cannot save changes. If the file has a 
modified read-only status from a version control system, you may 
not be able to check the file back into the system.

For more information about version control, see the CodeWarrior 
IDE User Guide and the documentation for your version control sys-
tem.

Understanding the Resource.frk folder
Constructor works with resources. On the Macintosh, resource in-
formation is stored in the resource fork. In Windows, resource forks 
do not exist, so Constructor stores all the resource data in a regular 
Windows file with the extension .rsrc.

However, the Macintosh OS duality between data fork and resource 
fork affects how Constructor works on Windows. When you create 
and save a new Constructor project file, Constructor creates the file 
and (if it doesn’t already exist) a folder named Resource.frk. In 
the Resource.frk folder, a file with the same name as the file you 
created is present—the file you created represents the data fork of 
the file, and the file of the same name in the Resource.frk folder 
represents the resource fork of the file. When you save a file, Con-
structor completes the following:

To Do this

Create a new project file Choose File > New Project File. 

Open a project file Choose File > Open Project File. 

Save a project file Choose File > Save.

Save a project file with a 
different name or in a 
different location

Choose File > Save As.

Close a project file Choose File > Close.
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• Creates an empty file in the folder you choose.

• Creates a Resource.frk folder if necessary.

• Creates another file with the same name inside the Re-
source.frk directory to hold resource information.

It is important to understand that there are two aspects to each Con-
structor file: the data aspect, which is a single file, and the resource 
aspect, which is also a single file. Although these files have the same 
name, the resource file is and must be in the Resource.frk folder 
in order for Constructor to work properly with your data and to 
move files from one platform to another. See “Moving a Constructor 
File Between Platforms” for more information.

Moving a Constructor File Between Platforms

To successfully move a file between the Macintosh and Windows 
platforms (and vice versa) you must consider how Constructor han-
dles the differences between the Macintosh and Windows operating 
systems. You may move files via a network connection or disk.

NOTE: Before transferring files between Macintosh and Win-
dows on a disk, make sure that PC Exchange software is running 
on your Macintosh. The PC Exchange system extension is re-
quired in order to read MS-DOS-formatted diskettes.

Moving a File from Macintosh to Windows
To transfer a file over a network:

When transferring a file from a Macintosh to Windows over a net-
work, only the Macintosh resource file is transferred to the Win-
dows system (because the data fork of the Macintosh Constructor 
project file is empty). Once the file has been transferred, add a 
.rsrc extension to the transferred file and place it in a Re-
source.frk folder. Next, create a “phantom” file of the same 
name and place it outside the Resource.frk folder. This empty 
file represents the “data fork” of the file. This is the file you open 
from Constructor on a Windows machine.
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To transfer a file via disk:

Copy the file from the Macintosh computer onto an MS-DOS-for-
matted disk; the Macintosh OS automatically splits the file and 
stores the resource fork in an invisible directory named Re-
source.frk, and the data fork of the file appears on the disk. 

When you open the disk in Windows, both the actual file (data part) 
and the Resource.frk directory appear. Copy both parts of the 
file to the final destination on your Windows system—treat the data 
part of the file as the regular file, and move the resource part of the 
file into a Resource.frk directory.

Moving a File from Windows to Macintosh

Before you move a file from a Windows system onto the Macintosh, 
make sure that the PC Exchange control panel is installed on your 
Macintosh. 

To transfer a file via disk:

On your Windows system, make sure that a Resource.frk folder 
appears at the top level of the disk (this is a requirement of the Mac-
intosh file system); then copy both parts of the file you want to 
move to the disk. Place the data part of the file on the top level of the 
disk, and place the resource part inside the Resource.frk folder.

Note that when you open the disk on a Macintosh, two issues occur, 
which will be automatically handled by PC Exchange: the Re-
source.frk folder is invisible, and the file is in two pieces (rather 
than a single file with two forks as is expected on Macintosh OS). 

Drag the visible .rsrc file from the Windows disk onto your Mac-
intosh desktop; then launch Constructor and open the file. (You can-
not double-click a file from the desktop to open it in Constructor; 
you must launch Constructor and open the file within the program.) 
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Source Code Generation
Constructor optionally creates a C header file containing preproces-
sor definitions for the resources defined in your Constructor for 
Palm OS project file. You may include this header file in the C 
source code files in your Palm OS application’s project.

To generate a C header file for a Constructor for Palm OS project: 

1. Open the Constructor project file.

See “Managing Files with Constructor.”

2. Turn on source code generation.

Select the Auto Generate Header File option in the Project Settings 
section of the Constructor project file’s window. You may have to 
expand this part of the window to see the Project Settings section. 
See “Project Window” for more information.

3. Name the header file.

By default Constructor names the header file after the project file 
and adds _res.h. To specify a different name, click the text field of 
the Header file name option entry in the Project Settings section of 
the Constructor project file’s window; then enter a name. If you do 
not add an .h file name extension, Constructor adds _res.h .

4. Set header file options.

For descriptive comments to appear in the generated source code, 
select the Include Details in header option in the Project Settings 
section of the project file window. 

Now, each time you save changes to the Constructor project file, 
Constructor updates the C header file associated with it. If the 
header file doesn’t exist in the same folder as the Constructor 
project file, Constructor creates a new one.

Related Information

See “Save” and “Generate Source Code.”
Constructor for Palm OS CNP–21



Constructor Fundamentals
Project Window
Project Window
The Project window is used to create and manage resources. When 
you open a Constructor project file, the Project window lists each 
type of resource and the individual resources available for each 
type. 
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Figure 2.1 A Constructor for Palm OS project window

The Project window is organized into the following sections: 

• Resource Type and Name List

• File Control Status

• Project Settings

Resource Type and Name List 

Each grey bar in the Project window reflects a resource type. The 
following types of resources are available: 
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• Forms

• Menu Bars

• Menus

• String Lists, Strings, App Info String Lists

• Alerts

• Icons, Multibit Icons, Application Icon Families, Bitmap Fam-
ilies

• Bitmaps

Once you have created at least one resource, a triangle appears to 
the left of the resource heading. Click the triangle to expand or col-
lapse the list of resources. 

When a resource has changed but has not been saved, a dot appears 
to the left of that resource, as shown in Figure 2.2.

Figure 2.2 A changed resource

You may have multiple projects open simultaneously, and copy re-
sources from one to another.

For more information about the resources in a project file, see “Con-
structor’s Resource Types.”

File Control Status

The file privileges icon in the lower left corner of the Project win-
dow indicates the read/write status of the file, usually with respect 
to a source code control system. The file privileges icon works just 
like the same icon in the CodeWarrior IDE. For information on this 
topic, see the IDE User Guide section on file privileges.
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Project Settings

The Project Settings section of a project window contains options 
that apply to an entire project.

By default, the Project Settings section is displayed; to hide the 
Project Settings section, click the small triangle at the left corner 
above the section.

Generate App Resources option

When selected, instructs Constructor for Palm OS software to in-
clude a version resource ('tver') and an application icon name re-
source ('tAIC') in the project’s resources. Note that this option is 
turned off by default. 

When deselected, the Application Icon Name option and Version 
String option items are dimmed; Constructor does not generate a 
version resource ('tver') or an application icon category ('tAIC') 
resource.

Display/hide Project 
Settings

Project Settings section 
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Application Icon Name option

Contains the text to place in the project’s application icon name re-
source ('tAIN'). Constructor places the text in this field into a ap-
plication icon name resource. This field is limited to 31 characters.

If an application has a 'tAIN' resource, Palm OS software displays 
the text in the resource under the application icon when the user 
taps the Applications button on a Palm Computing® device. If an 
application doesn’t have this resource, the application’s file name is 
used. 

The Application Icon Name option is dimmed if Generate App Re-
sources option is not selected.

Version String option

Contains the text to place in the project’s version resource ('tver'). 
The format of the text in this field should be:

majorVersion.minorVersion

where majorVersion represents the major version number and minor-
Version represents a minor version number. These two numbers are 
separated by a period (.). This field is limited to 15 characters.

This option is dimmed if Generate App Resources option is dese-
lected.

Default App Category option 

Specifies a default application category for an application when it is 
installed on a device. Resulting file type is tAIC. If you do not make 
an entry in the Default App Category field, the application is as-
signed to the Main application category by default.

Application Icon option

Specifies the icon resource ID of the icon that represents the applica-
tion when the user taps the Applications button on a Palm OS de-
vice.
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If the resource ID that you enter doesn’t match the ID of an icon re-
sources in the project, a Create button appears next to the Applica-
tion Icon field. Click Create to draw a new icon for the application. 
After creating the new icon, its resource ID appears in the Applica-
tion Icon field.

If the resource ID that you enter matches the ID of a icon resource 
already in the project, an Edit button appears next to the Applica-
tion Icon field. Click Edit to open the icon resource in a bitmap edi-
tor window. 

Entering an ID of 0 specifies that the application does not have an 
icon.

See also “Working With Icons & Bitmaps Overview.”

Auto Generate Header File option

When selected, instructs Constructor to generate a C header file (a 
“.h” file) that contains preprocessor definitions of the resources in 
the Constructor project file whenever the project file is saved. Use 
the Header file name option and Include Details in header option to 
customize the header file.

To generate a header file when Auto Generate Header File is dese-
lected, choose File > Generate Source Code.

Header file name option

Specifies the file name of the C header file that Constructor for Palm 
OS generates. If left empty, Constructor fills this field with the name 
of the project file with _res.h added to the file name.

If the file name doesn’t have an .h file name extension, Constructor 
adds _res.h to the file name.

This option is dimmed if Auto Generate Header File option is dese-
lected.
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Include Details in header option

Instructs Constructor to add descriptive comments for the items 
listed in the C header file.

This option is dimmed if Auto Generate Header File option is dese-
lected.

Keep IDs in sync option

Instructs Constructor to maintain resource ID consistency. When 
this option is selected, Constructor:

• keeps form resource IDs and internal form IDs consistent

• renumbers object IDs in a form when the form ID changes

See also “Adding Interface Items to a Form.”

Palm OS Target option 

The Palm OS Target option is used to select a target operating sys-
tem. Three options are available: 

• Palm OS 3.0x and earlier. Select this option for 3.0x or earlier 
systems.

• Palm OS 3.1 and later. Select this option for Latin-encoded 
Palm OS 3.1 and 3.2 systems. 

• Palm OS for Japan: Choosing the Palm OS for Japan option 
displays the silkscreen that appears on Japanese Palm de-
vices. Note that you can enter Japanese text in Constructor if 
you are using a Japanese system or if your computer has a 
Japanese Language Kit (Macintosh only). 

Note that if you enter Japanese text and later select another 
Palm OS target, the text is not translated into Roman charac-
ters. You must reenter the desired text once you select an-
other option.

Editor Windows
Each resource type has a resource editor. To open an individual re-
source for editing, use one of the following techniques:
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• Double-click the resource in the project window.

• Select the resource(s) and press the Return or Enter key.

• Select the resource(s) and choose Edit > Edit Resource. 

Constructor opens an editor window that allows you to modify the 
resource. Each kind of resource has a different editor window. Fig-
ure 2.3 shows the character string editor window.

Figure 2.3 Character string editor window

TIP: Macintosh To save all windows in Constructor, hold down 
Option and choose File > Save. 

TIP: Windows To save all windows in Constructor, choose Save 
All from the File menu.

See these topics for information about various types of resource edi-
tors: 

• Form Layout Window

• Menu Bar Editor Window

• String Editor Window

• Alert Layout Window

• Bitmap Editor Window
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Property Inspector Window
To open the Property Inspector Window, choose Window > Prop-
erty Inspector.

The Property Inspector window displays attributes of a selected 
item, which may be: 

• A resource in the Project Window

• A pane in a Layout Window or Hierarchy Window

• A menu or menu item in the Menu Bar Editor Window

When you select one of these items, its properties appear and can be 
edited in the Property Inspector Window. Figure 2.4 shows an ex-
ample of this window displaying properties for a resource.

Figure 2.4 Resource properties

The top of the window identifies the item whose properties are dis-
played. 

The Property Inspector Window remains synchronized with what-
ever other view is open. If you modify the data in the Property In-
spector, all other views on the same data update simultaneously. If 
you modify the data in some other view, for example, the Project 
Window), the Property Inspector updates its data at the same time.

To archive the content of the Property Inspector window for a spe-
cific view (to make sure its contents don’t change when you switch 
from one view to another) you can "pin down" the content by click-
ing the push pin icon in the upper-right corner of the Property In-
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spector window. After clicking the push pin, the Property Inspector 
window shows only the information for its associated view. To see a 
Property Inspector window for a different view, choose the desired 
view; then choose Window > Property Inspector. A new Property 
Inspector window appears for the different view.

For a discussion of how the Property Inspector works with various 
items in Constructor, see the topics listed in Table 2.2.

Table 2.2 Using the Property Inspector Window

User Interface Features
Constructor has many of the interface features. These include fea-
tures that support:

• Selection, for selecting items. 

• Moving, Copying, and Deleting, for relocating, duplicating, 
and removing items. 

• Lists, for working with an ordered group of items. 

• Text Editing, for modifying text. 

• Undo, for restoring items to a previous state.

The figures in this section use the Project window to illustrate the 
interface. The same techniques work in individual editor windows, 
when the technique is appropriate for the kind of data displayed in 
the window. Interface features are not available in all windows 
under all circumstances. 

To use the Property 
Inspector with

See this topic

Forms “Setting Form Properties”

Menu bars and menus “Setting Menu Bar Properties”

Character strings and 
help text

“Modifying a Character String”

Alerts “Setting Alert Properties”
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Selection

Constructor follows the standard behavior with respect to making 
selections. As a general rule, you must first select an item or items, 
and then perform an operation on the selection. 

To select or deselect items, use any of the following methods: 

• To select an item, click the item. 

• To extend the current selection, press Shift and click. 

• To select contiguous items in one movement, drag the 
mouse. As you drag, all items that intersect are selected, and 
remain selected when you release the mouse. Note that for 
marquee selection to work properly, you must begin drag-
ging in an empty area of the window. If you drag on an item, 
you move or copy the item instead of starting a marquee se-
lection.

• To select all items in a window, choose Edit > Select All. 

• To deselect, click outside of the selection. 

TIP: Macintosh OS For a layout window, dragging in a top-level 
view (an not inside an individual pane) starts a marquee selection. 
If you drag inside an individual pane, you select the pane and then 
move or resize it. Hold down the Control key when you begin a 
drag inside a pane to prevent moving or resizing the pane. 

TIP: Windows For a layout window, dragging in a top-level view 
(an not inside an individual pane) starts a marquee selection. If 
you drag inside an individual pane, you select the pane and then 
move or resize it.

Moving, Copying, and Deleting

To move or copy an item, drag the item. Dragging an item to a dif-
ferent location in the same window moves the item; dragging an 
item from one window to another window copies the item. 
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Macintosh OS To copy an item within the same window, hold 
down Option as you drag or when you drop the item. 

Windows To copy an item within the same window, hold down 
Alt as you drag or when you drop the item.

NOTE: Dragging To create a copy in the Project window, use the 
Edit > Duplicate command (see below).

Drag and drop also works in the bitmap editor, in both the Editing 
View and the Sample Views.

You can drop bitmaps onto either the Editing View or the Sample 
Views. If you drop on the Editing view, the original bitmap is scaled 
to fit. If you drop on the editing view, the bitmap does not scale.

In addition to drag and drop, the standard Cut, Copy, and Paste 
commands in the Edit menu work in the traditional manner at all 
appropriate times. You may also choose the Edit > Duplicate com-
mand to make a copy of an item in the same window.

Macintosh OS You can drag from the Sample Views to other 
windows in Constructor and applications that support drag and 
drop, including the Finder desktop and the Scrapbook.

Macintosh OS To delete an item, select it. Then press the Delete 
key, or use the Edit > Clear command from the menu.

Windows To delete an item, select it; then press Backspace. You 
can also use the Edit > Clear command.

TIP: When copying, duplicating, moving, or deleting a pane that 
contains other panes, your edits affect the container and its con-
tents.

Lists

Some Constructor windows, like the Project window, display lists of 
information. You can navigate through lists of items using the 
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arrow keys. Each time you press a key, the next or previous item in 
a list is selected. To extend a selection, hold down Shift, and then 
press an arrow key. 

Constructor displays triangle icons to open and close lists. Click a 
triangle to expand or collapse an associated list.

You can extend a selection in a list by holding down Shift and then 
pressing an arrow key. 

Text Editing

Many Constructor windows contain text entries, for example, the 
Project window displays a list of resource names. 

To activate a text item for editing, click the item; then move the cur-
sor away from the text, or wait a few seconds. The text becomes ed-
itable when a frame appears around the text or when the text inser-
tion cursor appears within the item. 

You navigate through text using the arrow keys. You select text by 
dragging through text; double-click a word to select the word. 

To move from one item to the next in a series of text fields, use the 
Tab key. 

Undo

Constructor provides single-level undo. Most operations can be un-
done (and subsequently redone) using the Edit > Undo/Redo com-
mand.

If the undo is unavailable after a given action, the Edit menu dis-
plays Can’t Undo. 
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This chapter provides information about modifying form resources 
using Constructor for Palm OS® software

Working with Forms Overview
Working with forms comprises two concepts: the Constructor win-
dows used to edit a form, and the tasks you perform on a form and 
its contents. 

The following topics are included in this chapter:

• Windows for Forms Windows you see while working on 
form resources.

• Editing Forms Tasks you perform on a form and its contents. 

Windows for Forms
This section discusses the Constructor windows you use to create 
and edit forms and their contents. The following windows are used: 

• Catalog Window, containing the user interface items you can 
add to a form.

• Form Layout Window, the editor window that shows a view 
of a Palm OS form.

• Hierarchy Window, the window that displays a list of the 
items within the form.

Catalog Window

The Catalog window lists the user interface items you can place in a 
form. 
Constructor for Palm OS CNP–35



Working with Forms
Windows for Forms
To open the Catalog window:

Choose Window > Catalog.

Figure 3.1 The Catalog window for Constructor for Palm OS

The Catalog window contains the items listed in Table 3.1. For a de-
scription of all the user interface items available for Palm OS, see to 
the Palm OS documentation.

Table 3.1 User interface items in the Catalog window for forms

User interface item Resource 
type

Purpose or behavior

'tBTN' Triggers an action after the item is de-
pressed then released within the but-
ton’s bounds.

'tCBX' Toggles on and off when tapped.

'tFLD' Accepts and displays user data entry in 
the form of text.

'tFBM' Acts as a placeholder for a bitmap re-
source.
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'tGDT' Acts as a placeholder for an applica-
tion-defined user interface item.

'tGSI' Displays the Graffiti shift indicator for 
punctuation, symbol, uppercase
shift, and uppercase lock. 

'tLBL' Displays non-editable text.

'tLST' Presents a box to the user containing a 
list of choices.

'tPUT' Shows the selection from a popup list 
and lets the user display an associated 
popup to change the selection.

'tPBN' Allows the user to choose only one 
push button within a group of push 
buttons. To specify that two or more 
push buttons are in the same group, se-
lect them, then use the Arrange > Make 
Object Group command. 

'tREP' Triggers a (typically) continuous action 
only while the item is depressed.

'tSLT' Shows a setting and lets the user dis-
play an associated dialog box to change 
the setting. For more information on di-
alog boxes see “Creating a Dialog Box.”

'tTBL' Displays a 2-dimensional array of infor-
mation.

'tSCL' Allows the user to control which por-
tion of a list or table is displayed. This 
item is not available when creating 
forms for version 1 of Palm OS.

User interface item Resource 
type

Purpose or behavior
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For information about adding items from the Catalog window to a 
form, see “Adding Interface Items to a Form.”

Form Layout Window

The Layout window is where you do most of your visual work in 
Constructor. This is the window in which you arrange user interface 
items in a form.

To open a form in a Layout window:

Do one of the following:

• Double-click a form resource in the Project window. 

• Select a form resource in the Project window and press Re-
turn or Enter.

Figure 3.2 The Form Layout window

To learn how to create and edit forms, see “Editing Forms.”
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Hierarchy Window

The Hierarchy window provides another way to examine a form; it 
displays a hierarchical listing of a form and its contents.

To view a form in a hierarchy window:

1. Open the form from the Project window.

2. Choose Layout > Show Object Hierarchy. 

Figure 3.3 The Hierarchy window

Editing Forms
This section shows you how to work with form resources. Use the 
information in this section to learn about: 

• Creating a Form

• Creating an About Box

• Creating a Dialog Box

• Setting Form Properties

• Adding Interface Items to a Form

• Adding Help to a Form

• Arranging Items in a Form

• Deleting Items in a Form
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TIP: To prevent runtime problems with forms, make sure the 
Keep IDs in sync option option is selected in the Project Settings 
section of the project window. This option ensures that resource 
and form IDs stay consistent.

Creating a Form

A Palm OS software application uses a form to hold a group of re-
lated interface items manipulated by the user. A Palm OS form is 
similar to a window on the Macintosh or in Windows. 

To create a form:

1. Do one of the following:

• Select the Forms icon in the Project window; then choose Edit 
> New Form Resource.

• Choose Edit > New Resource, choose Form from the Re-
source Type pop-up menu, enter a Resource Name and Re-
source ID, and then click Create to create the form. 

An untitled form resource is displayed in the Project window. For 
more information on using the project window, see “Resource Type 
and Name List.”

2. Press Return or Enter to open the form in a layout window. 

See “Form Layout Window” for more information. 

3. Add and arrange items in the form.

To learn about adding and arranging items in the new form, see 
“Editing Forms.”

Creating an About Box

An About Box is a form that displays information about a Palm OS 
application and its author. The type of form used for an About Box 
in a Palm OS application is usually a dialog box. For more informa-
tion, see “Creating a Dialog Box.” 
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Creating a Dialog Box

A dialog box is a form that displays information for the user to mod-
ify. Dialog boxes in Palm OS are modal, that is, a dialog box appears 
in front of other forms on the screen, forcing the user to interact be-
fore continuing. 

To create a dialog box:

1. Do one of the following:

• Click the Forms icon in the Project window to select it; then 
choose Edit > New Form Resource.

• Choose Edit > New Resource, choose Form from the Re-
source Type pop-up menu, enter a Resource Name and Re-
source ID, and then click Create to create the form. 

For more information on using the project window, see “Resource 
Type and Name List.”

2. Press Return or Enter to open the form in a layout window. 

See “Form Layout Window” for more information about the layout 
window.

3. In the Layout window, click the Modal option to make the form a 
modal dialog box. 

4. Add and arrange items to the dialog box.

To learn about adding and arranging items in the new form, see 
“Editing Forms.”

Setting Form Properties

Layout Properties determine how a form appears and how it will be 
used by a user. 

For information about the form layout window, see “Form Layout 
Window.”

Left Origin

Specifies, in pixels, the left-most edge of the form. 
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Top Origin

Specifies, in pixels, the top-most edge of the form.

Width

Specifies, in pixels, the width of the form. 

Height

Specifies, in pixels, the height of the form. 

Usable

Specifies the visibility of the form, either visible or invisible. If the 
Usable option is selected, the form is displayed in the Palm OS ap-
plication; if the option is not selected, the form is not displayed. 

See the Palm OS SDK documentation for more information about 
hiding and showing forms from a Palm OS application.

Modal

Specifies how events outside of the form boundary are interpreted, 
that is, if a user must interact with the form before continuing with 
other tasks. 

If the Modal option is selected, the form does not respond to tapes 
outside the form (this option is selected for dialog boxes). See “Cre-
ating a Dialog Box” for more information.

Save Behind

Specifies how the area behind the form appears on the screen. If 
Save Behind is selected, the Palm OS saves the area of the screen the 
form obscures; then restores the area when the form is hidden. 

Help ID

Specifies the help text resource ID that appears when the user taps 
the Help icon in a modal form. This field is only available if the 
Modal option is selected.
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To select a Help ID option: 

• If you enter a resource ID that does not match the ID of a 
charater string resource in the project, a Create button ap-
pears next to the Help ID field. Click Create to create a new 
character string.

• If the resource ID you enter matches the IDs of a character 
string resource in the project, an Edit button appears next to 
the Help ID field. Click Edit to open the character string re-
source in a string editor window to edit the help text for the 
form.

• Entering an ID of 0 indicates that the form does not have help 
text. 

See “Adding Help to a Form” and “Working with Character Strings 
Overview” for related information.

Menu Bar ID

Specifies the resource ID of the menu bar associated with the form.

To select a Menu Bar ID option: 

• If you enter a resource ID that does not match the ID of a 
menu bar in the project, a Create button appears next to the 
Menu Bar ID field. Click Create to create a new menu bar re-
source.

• If the resource ID you enter matches the IDs of a menu bar re-
source in the project, an Edit button appears next to the 
Menu Bar ID field. Click Edit to open the menu bar resource 
in a menu bar editor window.

• Entering an ID of 0 indicates that the form does not have a 
menu bar. 

See “Adding a Menu Bar to a Form” and “Working with Menu Bars 
and Menus Overview” for related information.

Default Button ID

Specifies the resource ID of the form’s default button. Palm OS soft-
ware simulates the tapping of this button when the form is dis-
missed.
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Form Title

Specifies the title of the form (displayed at the top of the form).

Adding Interface Items to a Form

An interface item is a visual object that appears in a form and pre-
sents information or allows the user to manipulate information. Ex-
amples of interface items are buttons, checkboxes, and editable text 
fields.

To add an interface item to a form:

• Copy and paste the item or drag it from another window. 

• Drag items from the Catalog Window onto the form. 

When you add a user interface item to a form, Constructor assigns 
the item a unique ID number. Note that Constructor does not allow 
you to change the ID of an item if the ID is already in use by another 
item in the current form. 

NOTE: To keep resource ID numbers of interface items in a form 
from conflicting with the ID numbers of items in other forms, Con-
structor imposes a limit of 99 user interface items in a form.

For a list of items you may add to a form, see “Catalog Window.”

For related information on resource ID numbering, see “Keep IDs in 
sync option.”

Adding Help to a Form

Palm OS software displays a modal form containing help text when 
a user taps the Help icon in the top right area of a modal form. 

Note that non-modal forms cannot use help text. For more informa-
tion on creating modal forms, see “Creating a Dialog Box.”
CNP–44 Constructor for Palm OS 



Working with Forms
Editing Forms
To add help to a form:

1. Open the form to which you want to add help. 

See “Form Layout Window” for more information.

2. Make sure the Modal option is selected. 

When the Modal option is selected, the Help ID field is displayed.

3. In the Help ID field, enter a resource ID. 

If you’ve already entered a character string to use as help text, enter 
that character string’s resource ID. Otherwise, enter a unique re-
source ID.

4. Create or edit the help text.

Click the button that appears next to the Help ID field. See “Help 
ID” for more information.

Adding a Menu Bar to a Form

If a form has a menu bar, the Palm OS software displays it when the 
user taps the Menus icon. 

To add a menu bar to a form:

1. Open the form to which you want to add a menu bar. 

See “Form Layout Window” for information.

2. In the Menu Bar ID, enter a resource ID.

If you’ve already created a menu bar and menus for this form, enter 
its resource ID. Otherwise, enter a unique resource ID.

3. Create or edit the menu bar and menus.

Click the button that appears next to the Menu Bar ID field. See 
“Menu Bar ID” for more information.

Arranging Items in a Form

This section provides information about the various ways you can 
arrange items in a form. 
Constructor for Palm OS CNP–45



Working with Forms
Editing Forms
To select an obscured item: 

If an item is obscured by another pane, do one of the following: 

Macintosh OS To select an item hidden by another, hold down 
Command and click the hidden item. Continue clicking until the 
item you want is selected. Release the Command key; then hold 
down Option and drag, resize, or double-click the hidden selected 
item. 

Windows To select an item obscured by another, hold down 
Control and click the hidden item. Continue clicking until the item 
you want is selected. Release the Control key; then hold down Alt 
and drag, resize, or double-click the hidden selected item.

To move an item: 

To move an item, do one of the following: 

Macintosh OS Begin dragging; then hold down Shift, Com-
mand, or Shift/Command to constrain the movement of the items 
being moved.

Windows Begin dragging; then hold down Shift, Control, or 
Shift/Control to constrain the movement of the items being moved. 

NOTE: Holding down Shift key before you begin dragging 
changes the selection. Be sure to begin dragging first; then hold 
down Shift. 

To nudge an item: 

Nudging lets you move an item one pixel at a time. To nudge an 
item, first select and then use the arrow keys to move the item.

Using a grid

Constructor provides a grid to help you arrange panes. 

To display or hide a grid: 

1. Open the desired form.

2. Choose Layout > Show Grid/Hide Grid to display the grid. 
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To align items to a grid:

Do one of the following:

• To snap all items to the grid, choose Layout > Snap to Grid/
Don't Snap to Grid. 

• To snap only a selected item to the grid, select the item; then 
hold down Ctrl (Windows) or Command (Macintosh) and 
continue dragging.

To set the grid size: 

Choose Layout > Edit Grid; then enter the desired grid spacing. 

To resize an item: 

Select the item; then drag a handle at the corner to resize the item. 

Deleting Items in a Form

To remove an item from a form, you must first select it. Once you’ve 
selected the item, do one of the following: 

• Press Delete or Backspace

• Choose Edit > Clear

• Choose Edit > Cut 

• Drag the item onto the trash can on the desktop (Macintosh 
only) 
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4
Working with Menu 
Bars and Menus
This chapter introduces Menu Bar resources and Menu resources, 
used to create menu bars and menus for Palm OS® software applica-
tions. In addition, information about how to add menu items to 
Menu resources is provided. 

Working with Menu Bars and Menus Overview
Menu bars and menus in Constructor are similar to those in dis-
played in software applications. In a software application, a menu 
bar resource defines the list of menu resources to include in the 
menu bar at runtime; in Constructor, the Menu Bar editor displays a 
list of menus and lets you modify them. 

The following topics are included in this chapter: 

• Menu Bars and Menus. How to create Menu Bar and Menu 
resources. 

• Editing Menu Bar and Menu Resources. How to edit Menu 
Bar and Menu resources. 

Menu Bars and Menus
This section shows you how to create Menu Bar and Menu re-
sources for your Palm OS software applications. 
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Creating a Menu Bar Resource 

A Palm OS software application uses a menu bar to provide a user 
with a list of menus. To display a menu bar and its menus, the user 
taps the Menu button on a Palm™ connected organizer.

In Constructor, there are two ways to create a Menu Bar resource. 
You can use either of two Menu Bar resource commands available 
from the Edit menu. 

To create a menu bar resource: 

In the Project window, click the Menu Bar resource icon; then use ei-
ther of the following methods to create a menu bar resource. 

Method 1

1. Choose the first Edit > New Menu Bar Resource command. 

An untitled Menu Bar resource appears in the Menu Bar resources 
section in the Project window. 

2. Click the untitled Menu Bar resource icon; then choose Window > 
Property Inspector.

3. In the Property Inspector, type a number for the Resource ID or ac-
cept the default number provided. 

4. In the Resource Name field, type the name of the Menu Bar re-
source; then close the Property Inspector.

Method 2

1. Choose the second Edit > New Menu Bar Resource command. The 
Create New Resource dialog box appears.

In the New Resource dialog box, Menu Bar is the selected resource 
type. 

2. In the Resource Name field, enter a name for the Menu Bar resource.

3. In the Resource ID field, enter a number for the Menu Bar resource.

4. Click Create to create the Menu Bar resource. 

Tip: You can use the Create New Resource dialog box to create 
any type of resource. Select the desired resource type from the Re-
source Type pull-down menu; then enter a Resource Name and 
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Resource ID. The resource is automatically added to the correct 
area of the project window. 

Menu Bar Editor Window

The Menu Bar editor window displays the collection of menu re-
sources contained in the menu bar resource. 

To open the Menu Bar editor window, do one of the following: 

• Double-click a menu bar resource in the Project window.

• Select a menu bar resource and press Return. 

• Select a menu bar resource and press Enter. 

The Menu Bar editor window displays:

• Descriptions of menu content, for example, Menu Text and 
Shortcut. 

• The menu bar, corresponding to the appearance of the menu 
bar in the application. 

• The menu command text, corresponding to the appearance 
of a menu command in the application. 

• The Graffiti® shortcut associated with the command.
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Figure 4.1 The menu bar editor window

Creating a Menu Resource 

There are two ways to create a Menu resource: from a Menu Bar ed-
itor window or from the Project window. When you create a Menu 
resource from a Menu Bar editor window, it is automatically associ-
ated with the selected menu bar; when you create a menu from the 
Project window, it is not initially affiliated with any menu bar re-
source. 

To create a menu from a menu bar editor window: 

1. Open a menu bar resource window using one of the methods de-
scribed in the “Menu Bar Editor Window” section.

2. Choose Edit > New Menu. An untitled menu name appears in the 
menu bar.

3. Type the name of the menu. 

4. Add and arrange menu items in the menu.

For information about adding items to menus and arranging menus, 
see “Editing Menu Bar and Menu Resources.”
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To create a menu from the Project window:

Method 1

1. Click the Menu resource icon in the Project window; then choose the 
first Edit > New Menu Resource command.

A new untitled menu appears in the Project window.

2. Using one of the methods described in the Menu Editor Window 
section, open the menu resource window. 

Method 2

1. Click the Menu resource icon in the Project window; then choose the 
second Edit > New Menu Resource command.

The Create New Resource dialog box appears, with Menu as the se-
lected resource type. 

2. In the Resource Name field, enter a name for the Menu resource.

3. In the Resource ID field, enter a number for the Menu resource.

4. Click Create to create the Menu resource. 

In addition to creating menus using the Menu Bar editor window 
and the project menu, you can add existing menus to the Menu Bar 
editor window. 

To add an existing menu resource: 

1. Open the Menu Bar resource using one of the methods described in 
the “Menu Bar Editor Window” section. 

2. Drag the desired menu resource from the project window onto the 
menu bar editor window. 

As you drag, a dotted gray line appears in the menu bar to indicate 
where the menu will be placed when you release the mouse button. 
You can rearrange the order of menus later. For more information, 
see “Arranging Menus.”

Menu Editor Window

The Menu editor window is nearly identical to the Menu Bar editor 
window with one exception—the Menu editor window displays a 
single menu, while the Menu Bar editor can display several menus. 
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To open a Menu editor window:

Do one of the following:

• Double-click a Menu resource in the Project window.

• Select a Menu resource and press Return. 

• Select a Menu resource and press Enter. 

Note that if a Menu Bar editor window is open, all single Menu re-
sources affiliated with the Menu Bar resource are dimmed in the 
Project window. To display a single menu, close the Menu Bar re-
source window that contains the multiple menu resources; then 
open the desired single menu from the Menu resource are of the 
Project window. 

Figure 4.2 The menu editor window

Editing Menu Bar and Menu Resources
This section provides instructions for editing menu bar and menu 
resources, including: 
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• Setting Menu Bar Properties

• Arranging Menus

• Deleting Menus

Setting Menu Bar Properties

You use the Inspector window to change the properties of a Menu 
Bar or Menu resource. The Inspector window includes the resource 
name and the resource ID. 

To change the properties of a menu bar resource: 

1. Select the Menu Bar resource in the Project window.

2. Choose Window > Property Inspector.

The Property Inspector window appears with the menu bar re-
source’s ID and name displayed. See “Property Inspector Window” 
for related information.

3. Enter a Resource ID, a Resource Name, and then close the Property 
Inspector to update the menu bar resource. 

To change the properties of a menu resource: 

1. Select the Menu in either the Menu Bar window in the Project win-
dow. 

The Property Inspector window appears with the menu bar re-
source’s ID and name displayed. See “Property Inspector Window” 
for related information.

2. Enter a Resource ID, a Resource Name, and then close the Property 
Inspector to update the menu resource. 

Arranging Menus

You can change the order of menus in the Menu Bar editor window. 

To arrange menus in the menu bar: 

1. Open the Menu Bar editor window containing the Menu resources 
you want.
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2. Drag the menu names within the menu bar. As you drag, a gray line 
appears to indicate where the menu will be positioned when you re-
lease the mouse button. 

Deleting Menus 

You can delete unwanted menus from the Project menu or from the 
menu bar editor window.

To delete a menu from a menu bar: 

Do one of the following: 

• In the Project window, select the menu you want to delete; 
then choose Edit > Remove Menu. 

• In the menu bar editor window, click the menu name to se-
lect it; then choose Edit > Remove Menu. 

Either of these methods remove a menu from a menu bar without 
deleting the menu’s resource from the project.

Creating Menu Commands
This section shows you how to create and manage menu com-
mands. All the tasks presented in this section may be performed in 
either the Menu Bar editor window or the Menu editor window. 

Note: As a general rule, the Menu Bar editor is more useful than the 
Menu editor because you can work with several menus. However, 
the Menu Bar editor does not display submenus, so you must use 
the Menu editor for submenus, pop-up menus, and so forth. 

Read these topics to learn about:

• Setting Menu Properties

• Adding a Command to a Menu

• Modifying a Command in a Menu

• Arranging Commands in a Menu

• Deleting Commands from a Menu
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Setting Menu Properties

Use the Inspector window to change the description and resource 
ID of a menu resource.

Warning: Changing a menu’s resource ID may corrupt menu bar re-
sources that refer to that menu.

To change a menu resource’s properties:

1. Select the menu resource in the Project window.

2. Choose Window > Property Inspector.

The Property Inspector window displays the menu resource’s ID 
and name.

3. In the Property Inspector window, click the value you want to 
change; then enter the new value. 

Adding a Command to a Menu

This section shows you how to add commands to Menu resources. 

To add commands to a menu:

1. Open the menu in a menu bar editor window or menu editor win-
dow.

See “Menu Bar Editor Window” or “Menu Editor Window” for 
more information.

2. Select a location for the command by selecting an item in the current 
Menu bar. The new command will appear after this selection. If 
there are no items in the menu yet, the new item becomes the first 
command on the menu. 

3. Choose New Menu Item or Edit > New Separator Item from the 
menu. 

Choosing New Menu Item inserts a new untitled menu choice. 
Choosing New Separator Item inserts a menu separator, which dis-
plays a thin gray line. 

4. Type the menu command’s name. 
Constructor for Palm OS™ Platform CNP–57



Working with Menu Bars and Menus
Creating Menu Commands
5. In addition, you may specify a Graffiti command stroke for the 
Menu command. To specify a command stroke, press Tab and type 
the letter for the command stroke.

Modifying a Command in a Menu
To modify a menu command: 

1. Open the menu in a Menu Bar editor window or menu editor win-
dow.

See “Menu Bar Editor Window” or “Menu Editor Window” for 
more information.

2. Click the command you want to change.

To change an item’s name, click it; then edit the item. To change the 
command’s Graffiti command stroke, click the item and then edit it. 

3. Press the Tab key to edit the next field.

Arranging Commands in a Menu

To move a menu command, drag it within the menu. A small arrow 
and a flashing horizontal line indicate where the menu item will be 
inserted when you release the mouse button.

You can also drag menu items from one menu to another in the 
same window or in different windows.

Deleting Commands from a Menu 

To remove one or more menu items from a menu, first select the 
item or items; then do one of the following: 

• Press Delete 

• Press Backspace 

• Choose Edit > Cut Menu Item or Edit > Clear Menu Item. 

• Drag the command onto the trashcan on the desktop (Macin-
tosh only)
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This chapter introduces Character String resources, used for data 
like help text and default values for text fields. 

Working with Character Strings Overview
Strings, stored in a 'tSTR' resource, are a common feature of Palm 
OS® software applications. Character string resources are used to 
hold data like help text, default values for text fields, and other in-
formation. Each 'tSTR' resource contains a text string.

This chapter provides instructions for how to manage and modify 
the contents of a character string resource, inlcuding: 

• Windows for Character Strings

• Editing Character Strings 

Windows for Character Strings
This section discusses the Constructor windows used to create and 
edit character strings: 

• String Editor Window, the window used to enter and edit 
text and set the display font for the character string.

• String List Editor Window, the window used to enter and 
edit a string list resource and set the display font. 
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String Editor Window

Use the String Editor window to enter and edit a character string re-
source ('tSTR') and specify in what font the string will be dis-
played.

To open a string in a string editor window:

Do one of the following: 

• Double-click a Strings resource in the Project window.

• Select a Strings resource in the Project window and press 
Enter or Return. 

Figure 5.1 The String Editor window

To learn how to create and edit character strings, see “Editing Char-
acter Strings.”

String List Editor Window

The String List Editor window is used to enter and edit a string list 
resource ('tSTL'). A string list resource is a related group of 
strings. Use the SysStringByIndex() routine to access a string 
within a string list resource.

To open a string in a String List editor window:

Do one of the following: 
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• Double-click a String Lists resource in the Project window.

• Select a String Lists resource in the Project window and press 
Return or Enter. 

Figure 5.2 The String List Editor window

App Info String List Editor window

Use the App Info String List Editor window to enter and edit a app 
info resource ('tAIS'). An app info string list resource is often 
used to hold an application’s initial categories in an application’s 
database. Use the CategoryInitialize() routine to access an 
app info string list.

To open a string in a App Info String List editor window: 

Do one of the following: 

• Double-click an App Info String Lists resource in the Project 
window.

• Select an App Info String Lists resource in the Project win-
dow and press Return or Enter.
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Figure 5.3 The App Info String List Editor window

Editing Character Strings
This section shows you how to work with text in Strings, String 
Lists, and App Info String Lists resources, including: 

• Creating a Character String

• Creating a Character String List

• Creating a Category String List

• Creating Help Text

• Modifying a Character String

• Deleting Character Strings

Creating a Character String
To create a character string resource:

1. Do one of the following: 

• Select the Strings icon in the Project window; then choose 
Edit > New String Resource. A new, untitled Strings resource 
appears in the Project window. 
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• From anywhere in the Project window, choose Edit > New 
Resource. Select String from the Resource Type pop-up 
menu, enter a Resource Name and Resource ID, and then 
click Create to add the resource to the Strings section of the 
Project window. 

For more information about using the Project window, see “Re-
source Type and Name List.”

2. Select the string; then press Return or Enter to open the string in a 
String editor window.

For more information, see “String Editor Window”.

3. Enter the character string and set its font. 

For information about setting the string font, see “Setting the String 
Font.”

Creating a Character String List
To create a character string list resource:

1. Do one of the following: 

• Select the String Lists icon in the Project window; then 
choose Edit > New String List Resource. A new, untitled 
string list resource appears in the Project window. 

For more information on using the project window, see “Re-
source Type and Name List.”

• From anywhere in the Project window, choose Edit > New 
Resource. Select String Lists from the Resource Type pop-up 
menu, enter a Resource Name and Resource ID, and then 
click Create to add the resource to the String Lists section of 
the Project window. 

2. Select the string list in the Project window; then press Return or 
Enter to open the string list resource in the String List Editor win-
dow. 

See “String List Editor Window” for more information.

3. Enter the character string list and set its font. For information about 
setting the string font, see “Setting the String Font.”
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Creating a Category String List

Category names may be stored in an App Info String List resource. 

To create list of category names for a database:

1. Do one of the following: 

• Select the App Info String Lists icon in the Project window; 
then choose Edit > New App Info String List Resource. An 
untitled resource appears in the Project window. 

For more information on using the project window, see “Re-
source Type and Name List.”

• From anywhere in the Project window, choose Edit > New 
Resource. Select App Info String Lists from the Resource 
Type pop-up menu, enter a Resource Name and Resource ID, 
and then click Create to add the resource to the App Info 
String Lists section of the Project window. 

2. Select the string list; then press Return or Enter to open the string 
list in a App Info String List editor window. See “App Info String 
List Editor window” for more information.

3. Enter the categories list and set the category list font. For informa-
tion about setting the string font, see “Setting the String Font.”

Creating Help Text

A character string resource is used to create help text or an online 
tip for a form or alert. 

To learn about adding an online tip to a form, see “Adding Help to a 
Form.” To learn about adding an online tip to an alert, see “Adding 
Help to an Alert.”

Setting String Properties

Use the Inspector window to change the description and resource 
ID of a string resource.

WARNING! Changing a string’s resource ID may affect other re-
sources that refer to that string. Be sure to update the properties of 
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any forms, alerts, and other resources that refer to string re-
sources you’ve modified.

To change a string resource’s properties:

1. Select the string resource in the Project window.

2. Choose Window > Property Inspector to open the resource in the 
Property Inspector window.

3. Enter the new value in the Value area to change the string resource’s 
properties. 

Modifying a Character String
To modify a character string’s contents:

1. From the Project window, open the string in either of the following 
ways:

• Double-click the string icon.

• Select the string; then press Return or Enter. 

See “String Editor Window”, “String List Editor Window”, and 
“App Info String List Editor window” for more information.

2. Edit the string’s text.

Note that some Palm OS characters may not appear correctly on 
your desktop computer. Select the View as Hex option to display 
and edit the text as hexadecimal values instead of ASCII characters. 
For more information, see “Text Editing.”

Setting the String Font
To set a string’s font: 

1. Open the string in an editor window.

See “String Editor Window”, “String List Editor Window”, and 
“App Info String List Editor window” for more information.

2. From the View as: pop-up menu, choose the string’s font. 

Constructor for Palm OS displays a list of Palm OS 3.0 fonts.
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Deleting Character Strings
To remove a String, String List, or App Info String List resource:

1. Select the resource in the Project window.

2. Do one of the following: 

• Press Delete or Backspace. 

• Choose Edit > Clear.

• Choose Edit > Cut.

• Drag the string resource onto the trash can (Macintosh only). 

To remove a string within a string list or app info string list:

1. Open the string list of app info string list in an editor window.

2. Click the number to the left of the string you want to remove. 
(When you click a number, the number is not highlighted.)

3. Do one of the following:

• Press Delete or Backspace. 

• Choose Edit > Clear.

• Choose Edit > Cut.

• Drag the string resource onto the trash can (Macintosh only). 
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Working with Alerts
This chapter introduces Alert resources, used to communicate im-
portant messages to users. 

Working With Alerts Overview
This chapter discusses how to manage and modify the contents of 
Alert resources.

Working with alerts comprises two concepts: the Constructor win-
dows used to create and edit an alert resource, and the tasks you 
perform when working with alert resources. 

• Windows for Alerts Windows you use to work on alert re-
sources. 

• Editing Alerts Tasks you perform on alert resources. 

 Windows for Alerts
This section discusses the Constructor windows you use to create 
and edit alert resources and their contents. 

• Alert Layout Window The editor window that displays a 
view of a Palm OS® software alert box.

Alert Layout Window

The Layout window is where most visual work is completed. For 
example, you use the Layout window to specify the text and buttons 
that appear in an alert resource. 

To open an Alert resource: 

1. Select an alert resource in the Project window.
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2. Do one of the following: 

• Double-click an Alert resource in the Project window.

• Select an Alert resource in the Project window and press Re-
turn or Enter.

Figure 6.1 The Alert Layout window

Editing Alerts
This section shows you how to work with alert box resources. Use 
this section to learn about:

• Creating an Alert

• Setting Alert Properties

• Adding Help to an Alert

• Setting the Alert’s Message

• Adding Buttons to an Alert

• Deleting Buttons from an Alert
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Creating an Alert

An alert resource is used to communicate an important message to a 
user. The user must respond to the alert before they continue using 
the application. 

To create an alert resource: 

1. Do one of the following: 

• Select the Alert icon in the Project window; then choose Edit 
> New String Resource. A new, untitled Strings resource ap-
pears in the Project window. 

• From anywhere in the Project window, choose Edit > New 
Resource. Select Alert from the Resource Type pop-up menu, 
enter a Resource Name and Resource ID, and then click Cre-
ate to add the resource to the Alert section of the Project win-
dow. 

For information about using the Project window, see “Resource 
Type and Name List.”

2. Select the Alert resource; the press Return or Enter to open the Alert 
resource in an Alert layout window. 

For more information, see the “Alert Layout Window” section. 

3. Add and arrange items in the alert.

To learn how to add and arrange items in the alert, see “Editing 
Alerts.”

Setting Alert Properties

The Alert Properties section of the Alert layout window lets you 
control how an alert appears and how it will be used by the user. 

For information about the Alert layout window, see “Alert Layout 
Window.”

Alert Type

Specifies the nature and importance of the alert message. 
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From the Alert Type pop-up menu, choose one of the items listed in 
Table 6.1.

For information about designing alert boxes, see the Palm OS SDK 
Reference manual. 

Table 6.1 Items in the Alert Type pop-up menu

Help ID

Specifies the resource ID of the help text that appears when the user 
taps the Help icon in an Alert box.

If you enter a resource ID that does not match an existing character 
string resource in the project, a Create button appears next to the 
Help ID field. Click Create to enter a new character string in the 
String editor window. 

If the resource ID that you enter matches the ID of a character string 
resource already in the project, an Edit button appears next to the 
String Help ID field. Click Edit to open the character string resource 
in a String editor window; then edit the help text for the Alert box.

Entering an ID of 0 means that the alert does not have help text.

Choosing this item Displays To indicate that 

Information The user should be aware 
of something, but it will 
not cause problems at a 
later time. 

Confirmation The user must acknowl-
edge the alert before con-
tinuing. 

Warning The application will ini-
tiate an irreversible ac-
tion. 

Error A error has developed 
that cannot be reversed.
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See “Adding Help to an Alert” and “Working with Character 
Strings Overview” for related information. 

Default Button

Specifies the resource ID of the form’s default button. Palm OS soft-
ware simulates the tapping of this button when the form is dis-
missed.

Title

Specifies the title of the alert, which appears at the top of the alert 
dialog box. 

Message

Specifies the text that appears in the body of the alert. Enter text that 
clearly describes the problem or issue. 

Button Titles

Displays a list of the a list of the button or buttons displayed in the 
Alert dialog box. 

For information about adding buttons to or deleting buttons from 
an alert, see “Adding Buttons to an Alert” and “Deleting Buttons 
from an Alert.”

Adding Help to an Alert

When a user taps the Help icon at the top right of the Alert box, 
Palm OS software displays a modal form containing help text. Op-
tionally, you may add help to the alert box. 

To add help to an alert:

1. Open the Alert resource from the Project window. 

See “Alert Layout Window” for information about how to open 
Alert resources. 
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2. Enter a resource ID in the Help ID field.

If you’ve already entered a character string to use as help text, enter 
that character string’s resource ID. Otherwise, enter a unique re-
source ID.

3. Click the button that appears next to the Help ID field—(Create or 
Edit, respective to the Help ID you enter.) 

4. Enter or edit the desired help text. 

5. Click the button that appears next to the Help ID field. See “Help 
ID” for more information.

Setting the Alert’s Message

The Alert resource’s message text describes the situation or issue the 
user must acknowledge. 

To define the Alert message: 

1. Open the Alert resource from the Project window. 

See “Alert Layout Window” for more information.

2. In the Message field, enter the message text you want.

3. Either close the Alert window or move to another field. 

Adding Buttons to an Alert

Buttons in an Alert resource let the user dismiss or act on a variety 
of choices. 

To add buttons to an alert:

1. From the Project window, open the Alert to which you want to add 
a button. 

See “Alert Layout Window” for more information.

2. Click Button Titles in the Alert Properties section of the Alert win-
dow; then choose Edit > New Button Title. A new entry appears in 
the Button Titles list.

3. Click in the field to the right of the button title you want; then enter 
the text for the button. 
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Deleting Buttons from an Alert
To remove a button from an alert:

1. From the Project window, open the Alert from which you want to 
delete a button. 

See “Alert Layout Window” for more information.

2. Click a button ID to select the button you want to delete. (If the list 
of buttons in the alert layout window is hidden, expand the Button 
Titles list.

3. Choose Edit > Delete Button Title.
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7
Working with Icons 
& Bitmap Images
This chapter introduces the Constructor’s bitmap editor, used to 
create and modify bitmaps, icons, bitmap families, and icon families 
within a variety of resources. 

Working With Icons & Bitmaps Overview
Constructor has a simple, powerful, and intuitive bitmap picture 
editor. Constructor uses a single bitmap editor to modify bitmaps in 
a variety of resource types:

• Icons

• Pictures

Notes: Palm OS® software version 3.0 or higher is required for 
grayscale icons. Make sure that your application verifies the sys-
tem software and displays the appropriate image type for the ver-
sion of the system software you are using. See “Icons in Palm OS 
3.5” for more information.

Grayscale and compressed bitmap images must follow a special 
naming convention to be recognized by Palm OS 3.0 software. 
See “Bitmap Images in Palm OS 3.5” for more information.

This chapter shows you how to manage and modify the contents of 
bitmap resources, including: 

• Bitmap Families. In Constructor 1.5, you can create and store 
up to four bitmaps rendered in different bit depths. 

• Application Icon Families. In Constructor 1.5, you can create 
and store up to four application icons rendered in different 
bit depths. 
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• Icons in Palm OS 3.5 How to upgrade icons to multibit (gray-
scale) icons and make sure they are recognized by any ver-
sion of Palm OS software.

• Bitmap Images in Palm OS 3.5 How to name bitmap images 
to take advantage of Palm OS 3.0 features.

• Bitmap Editor Window Identifying various parts of the edi-
tor window.

• Using the Bitmap Editor Tools A description of each bitmap 
editor tool and how to use them. 

• Editing Icons & Bitmaps Tips and ideas for using the bitmap 
editor. 

Bitmap Families
The bitmap familiy resource element (tBMF) lets you store up to 
four bitmap images rendered in different bit depths in a single re-
source. Note that this type (tBMF) does not reside in the resulting 
.prc—it conveys to PalmRez that the set of bitmaps is to be grouped 
in a single tbmp resource. 

The following rules apply to bitmap families: 

• A maximum of four bitmaps can be included in one bitmap 
family

• Bitmap images must be stored in increasing order of bit 
depth, and the bit depths must be unique.

• The height and width of all bitmaps must be identical. 
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To create a bitmap family resource:

1. Select the Bitmap Family Resource icon in the Project window. 

2. Choose Edit > New Bitmap Family Resource; then double-click the 
untitled icon under the resource to open the Bitmap Family dialog 
box. 

Follow the instructions later in this chapter to use the tools to create 
the bitmap.

Bitmap Family icon
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Application Icon Families
The application icon family resource element (tAIF) lets you store 
up to four icons rendered in different bit depths in a single resource. 
The resulting type in the prc is tAIB (instead of tBMP).

The following rules apply to application icon families: 

• The maximum width and height is 22x22, or 9 x13 for a small 
icon. 

• A maximum of four icons can be included in one application 
icon family. 

• Icons must be stored in increasing order of bit depth, and the 
bit depths must be unique.

To create an application icon family resource:

1. Select the Application Icon Family resource in the Project window. 

App Icon Families icon 
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2. Choose Edit > New Application Icon Family; then double-click the 
untitled icon under the resource to open the Application Icon Fam-
ily dialog box. 

Follow the instructions later in this chapter to use the tools to create 
the application icon.

Icons in Palm OS 3.5
Constructor lets you create two types of icons: 

• Black and white icons, for use with versions of the Palm OS 
earlier than version 3.0

• Multibit (grayscale) icons, for use with Palm OS software ver-
sion 3.0 and later 

• Color icons, using predefined color palettes that come with 
the Palm OS software. 

The multibit icon editor lets you to create two icons: a black and 
white icon, used by any version of the Palm OS software, and a 
multibit icon, used by Palm OS 3.0 and later software. The Palm OS 
software automatically chooses the right icon within a multibit icon 
resource to display in your application. See the Palm OS documen-
tation for more information.
Constructor for Palm OS CNP–79



Working with Icons & Bitmap Images
Icons in Palm OS 3.5
When creating new icons for an application, be sure to use the 
multibit icon editor so that your icons are recognized by any version 
of Palm OS software.

The topics in this section are:

• Updating Older Icons

• Important Icon Numbering and Size Conventions

Updating Older Icons

You use the multibit editor to create both a black and white and a 
grayscale icon that share the same ID. Having both icons available 
ensures that the correct icon is displayed, regardless of the version 
of the Palm OS software. 

To update a black and white icon to a multibit icon: 

1. Open the Constructor project containing the black and white icon 
you want to update. 

2. From the Icon area of the Project window, double-click the desired 
icon to open it in the Icon editor window.

Figure 7.1 Icon Editor Window

In the top right area of the window, a black and white sample icon 
appears. 

3. Choose Edit > Select All; then choose Edit > Copy to copy the black 
and white sample icon to the Clipboard.

Next, you’ll create a multibit icon.

Actual size
icon sample
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4. In the Project window, click the Multibit Icons icon; then choose 
Edit > New cicn Resource. 

A new, untitled multibit icon resource appears.

5. Click the ‘untitled’ name text to select it; then rename the icon with a 
new name. Be sure to name the multibit icon something different 
than the original black and white icon. 

6. Double-click the renamed icon to open it in the Cicn editor window.

Figure 7.2 Multibit icon in CICN Editor window

7. Click the B&W sample view in the top-right corner of the Cicn win-
dow; then choose Edit > Paste to paste the old icon from the Clip-
board. 

8. Next, click the Color sample view and choose Edit > Paste again to 
paste the older icon onto the canvas area. This Color sample view 
shows the grayscale version of the icon (which is still black and 
white, because it has not been edited). 

9. With the Color sample view selected, you can now edit the black 
and white icon with gray values to make it a grayscale icon.

For information about drawing and editing icons, see “Editing Icons 
& Bitmaps.” For information about working with two versions of 
the same icon, see “Viewing Sample Views.” 
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Important Icon Numbering and Size 
Conventions

After updating black and white icons to multibit icons, make sure 
that all versions of Palm OS software recognize and display your 
application’s icons accurately by following the conventions listed in 
Table 7.1.

For information about changing a resource’s ID, see the “Property 
Inspector Window”. 

Table 7.1 Icon IDs and Dimensions

Bitmap Images in Palm OS 3.5
To take advantage of the grayscale bitmap display features in Palm 
OS software version 3.5, follow the naming conventions in Table 7.2.

By default, if the name of a bitmap does not start with one of the 
prefixes provided in Table 7.2, any version of the Palm OS software 
displays the bitmap in black and white. 

For information on changing a resource’s name, use “Property In-
spector Window”. 

The multibit 
icon with this 
ID:

Should be the following size:

1000 22 pixels high by 22 pixels wide, which is the 
entire size of the canvas presented by Con-
structor in a multibit icon editor window.

1001 The top left corner of the multibit icon editor’s 
canvas, 9 pixels high by 15 pixels wide. Pixels 
outside this rectangle are ignored by Palm OS 
software.
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NOTE: The naming conventions in Table 7.2 are recognized only 
by Palm OS software version 3.0 and higher. Earlier versions of 
Palm OS software can only display black and white (1-bit per 
pixel) images, so be sure your application verifies the system ver-
sion at runtime before displaying bitmap images.

Table 7.2 Bitmap naming conventions for Palm OS 3.0 and higher

Bitmap Editor Window
Constructor uses the same bitmap editor, with a few small differ-
ences, for all resources containing bitmaps.

The Constructor bitmap editor has the following components:

• Tool Palette Tools used to control drawing operations.

• Drawing on the Canvas The area where you draw, usually 
displayed in a magnified view called fat bits. 

• Viewing Sample Views Actual-size representations of icons. 

If the bitmap 
resource’s name 
begins with:

It is displayed by Palm OS 3.0 software 
as:

/-2/ A grayscale image with 2 bits per pixel

/-1/ A black and white image with 1 bit per 
pixel

/-c/ Compresses the bitmap resource to save 
memory

/-c-2/ Compresses the resource and displays it as 
a 2-bit grayscale image

/-c-1/ Compresses the resource and displays it as 
a black and white image
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Tool Palette

The tool palette provides a set of tools for working with bitmap 
icons. To select a tool in the tool palette; click it. 

Table 7.3 The Bitmap Editor Tools

Tool Icons Purpose

Lasso Tool Selects an irregularly shaped 
area (available on Macintosh 
only). 

Marquee Tool Selects a rectangular area.

Text Tool Adds text to a bitmap (available 
on Macintosh only). 

Pencil Tool Draws pixel by pixel, usually 
with the foreground color.

Eraser Tool Erases pixels with the back-
ground color

Paint Bucket 
Tool

Fills an area of contiguous pixels 
of one color with current pattern.

Dropper Tool Sets the foreground or back-
ground color (also affects pattern 
color).

Line Tool Draws a line with the foreground 
color.

Rectangle Tools Draws a filled rectangle using 
the current pattern.

Rectangle Tools Draws a rectangle outlined with 
the foreground color.
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Drawing on the Canvas

The canvas is the main area of the Constructor bitmap editor win-
dow. You draw and edit the contents of the canvas area to modify 
the bitmap icon it represents, regardless of the kind of resource in 
which that bitmap appears.

The canvas area displays a magnified view of an icon. Each magni-
fied bit, sometimes called a fat bit, represents a single pixel in the ac-
tual size bitmap. 

To edit a bitmap, select a tool from the Tool Palette, then move the 
cursor onto the canvas area. When the cursor is positioned in the 
canvas area, the cursor changes to reflect the currently selected tool. 

As you edit the bitmap on the canvas, the Viewing Sample Views 
are updated. 

The canvas supports the usual mechanisms for transferring infor-
mation between windows and between applications: Cut, Copy, 

Rectangle Tools Draws a filled rounded rectangle 
using the current pattern.

Rectangle Tools Draws a rounded rectangle out-
lined with the foreground color.

Oval Tools Draws a filled oval using the cur-
rent pattern. 

Oval Tools Draws an outlined oval, using 
the foreground color. 

Pattern Tool Sets the fill pattern, based on the 
foreground and background col-
ors.

Color Tool Sets the foreground or back-
ground color.

Tool Icons Purpose
Constructor for Palm OS CNP–85



Working with Icons & Bitmap Images
Using the Bitmap Editor Tools
and Paste. You can also drag and drop a bitmap from the Sample 
View of one bitmap onto the canvas area of another bitmap. 

When you drop an item on the canvas, the original image is not re-
sized to fit the new canvas dimensions. If the bitmap is larger than 
the canvas, it is cropped to fit onto the current canvas. 

Macintosh OS You may drag from another Constructor win-
dow, or from an application that supports drag and drop, such as 
the Finder or the Scrapbook.

Viewing Sample Views

Sample views are displayed at the right side of the Icon editor or 
cicn editor window. The sample views display icons at actual size. 

If more than one sample view is available, each sample view repre-
sents either a different related resource or a different portion of the 
same resource. The canvas area displays the currently selected sam-
ple view, which is outlined in black. To switch from one sample 
view to another, click the sample view icon you want. 

You can drag and drop sample views in the same window or be-
tween two discrete windows. 

Macintosh OS You may also drag bitmap images between Con-
structor and other applications that support drag and drop. If you 
drop a bitmap from a different source onto a sample view in a Con-
structor editor window, the bitmap is scaled to fit Constructor’s can-
vas size. In addition, if the sample view you drag and drop contains 
more colors than the bitmap you’re dragging to, excess colors are 
automatically converted to the sample views color palette. 

Using the Bitmap Editor Tools
This section provides information about the individual tools on the 
Tool Palette. 

• Lasso Tool

• Marquee Tool
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• Text Tool

• Pencil Tool

• Eraser Tool

• Paint Bucket Tool

• Dropper Tool

• Rectangle Tools

• Oval Tools

• Line Tool

• Pattern Tool

• Color Tool

Lasso Tool 

The lasso tool creates irregularly shaped selections by letting you 
drag the mouse in a freehand motion. (The lasso tool is available 
only for the Macintosh.)

To create a selection using the lasso tool:

1. Click the lasso tool in the tool palette.

2. Drag the lasso tool around the shape you want to select. As you 
drag, a thin line follows to create a selection path. 

3. Close the path in either of the following ways:

• Cross the starting point of the path to end the path.

• Release the mouse button anywhere to draw a selection that 
ends by drawing a straight line between the starting point 
and the point at which you release the mouse button. 

The lasso tool ignores pixels in the current background color. If an 
object is surrounded by a background color, drawing the lasso 
loosely around the object and then releasing the mouse button auto-
matically tightens around the object to select it. 

Double-click the lasso tool to select the outermost outline of non-
background-color pixels in the canvas.
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See also “Tool Palette,” “Marquee Tool,” and “Selecting Pixels.”

Marquee Tool

The marquee tool creates rectangular or square selections. 

To create a selection using the marquee tool:

1. Click the marquee tool in the tool palette.

2. Do one of the following:

• Drag to create a rectangular selection.

• Hold down Shift and drag to constrain the selection to a 
square.

TIP: Double-click the marquee tool in the tool palette to select 
the entire canvas area. 

See also “Tool Palette,” “Lasso Tool,” and “Selecting Pixels.”

Text Tool

The text tool is used to enter text in a bitmap. ((The text tool is avail-
able only for the Macintosh.)

To create text:

1. Click the text tool in the tool palette.

2. Click in the canvas area to set an insertion point; then type the text 
you want. 

The initial position of text defines the margin, either left or right, de-
pending on the justification settings. By default, text wraps at the 
edge of a bitmap; for a forced return, use Return or Enter. 

3. Use the Font and Style menus to choose text characteristics. By de-
fault, text appears in the foreground color, and may have only one 
font, style, and color per entry. 
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Once you complete a text entry, it becomes a bitmap image and is 
not longer editable as text. You can however, edit the pixels that de-
fine the text on a pixel-by-pixel basis.

Note that the text editor does not support the Cut, Copy, or Paste 
commands. 

TIP: To increase or decrease font size by one point as you enter 
text, type Command-up arrow or Command-down arrow, respec-
tively.

See also “Tool Palette.”

Pencil Tool

The pencil tool draws single pixels or lines of pixels using the fore-
ground color. The size of the pencil is one pixel, and cannot be 
changed. 

To use the tool, select it in the tool palette. Clicking an existing pixel 
changes it to the current foreground color; clicking a blank area of 
the canvas adds a pixel using the current foreground color. 

If you click and drag the pencil, each pixel in your path changes to 
the foreground color. If the first pixel clicked is already in the fore-
ground color, then the pencil draws in the background color.

TIP: Change any non-foreground color pixel to the background 
color by double-clicking the desired pixel with the pencil.

To constrain the pencil to a straight line, press Shift before you 
begin dragging. The pencil is constrained to move in a straight line, 
either horizontally or vertically. 

See also “Tool Palette”, “Paint Bucket Tool,” and “Line Tool.”
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Eraser Tool

The eraser tool erases pixels. As you drag to erase pixels, the current 
background color is revealed. Be sure to set the background color to 
white if you want the eraser tool to reveal a white background. 

To use the eraser tool: 

1. Click the eraser tool in the tool palette.

2. Drag in the canvas area over the pixels you want to erase. 

3. If desired, constrain the eraser to a straight line by pressing Shift be-
fore you begin dragging. 

TIP: Double-click the eraser tool to erase the entire canvas. 

See also “Tool Palette.”

Paint Bucket Tool

The paint bucket tool fills an area with the current pattern. Pattern 
colors are based on the current foreground and background colors. 

To use the paint bucket tool: 

1. Click the paint bucket tool in the tool palette to select it.

2. Select a pattern from the pattern pop-up menu. 

3. Click the paint bucket tool in the canvas area to add the current pat-
tern to the canvas. 

Note that clicking in an enclosed area (an area of contiguous pixels 
that start and end at the same point) may produce varied results. 

Note: The paint bucket tool fills an area with the current pattern, 
not the current foreground color (although the pattern is based on 
the current foreground and background colors). To fill an area 
with either the foreground or background color, select the fore-
ground or background solid color swatch in the pattern menu be-
fore clicking the paint bucket tool in the canvas area. 
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See also “Tool Palette,” “Pattern Tool,” and “Color Tool.”

Dropper Tool

The dropper tool lets you set foreground and background colors. 

To use the dropper tool: 

1. Click the dropper in the tool palette. 

2. Do either of the following: 

• To set the foreground color, position the dropper on the can-
vas and begin dragging. As you drag, the foreground swatch 
changes color. Release the mouse button when the color you 
want is displayed in the foreground swatch. 

• To set the background color, position the dropper on the can-
vas, hold down Shift, and then begin dragging. As you drag, 
the background swatch changes color. Release the mouse 
button when the color you want is displayed in the back-
ground swatch. 

Tip for Macintosh: You can set foreground and background color 
at any time without selecting the dropper tool. Option-click a pixel 
to set the foreground color. Shift-Option-click a pixel to set the 
background color.

Tip for Windows: You can set foreground and background color 
at any time without selecting the dropper tool. Alt-click a pixel to 
set the foreground color. Shift-Alt-click a pixel to set the back-
ground color.

Line Tool

The line tool draws lines using the foreground color. The line tool 
has a default width of 1 pixel, which may not be changed.

To use the line tool: 

1. Click the line in the tool palette. 

2. Position the pointer in the canvas area; then do one of the following: 
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• Drag to draw a line. 

• Hold down Shift, and then drag to draw a line constrained to 
45° angle. 

See also “Tool Palette” and “Pencil Tool.”

Rectangle Tools

You use the filled and empty rectangle tools to draw filled and out-
line rectangles. The filled rectangle tool fills a rectangle with the cur-
rent pattern, and the empty rectangle tool creates an outlined rect-
angle using the current foreground color.

To use the rectangle tools: 

1. Select either the filled rectangle tool or the empty rectangle tool and 
position it in the canvas area.

2. Do one of the following:

• For a filled rectangle, drag from one edge to another to create 
a rectangle filled with the current pattern.

• For an empty rectangle, drag from one edge to another to cre-
ate an outlined rectangle. The current foreground color cre-
ates a 1-pixel outline. The width of the outline may not be 
changed. 

3. To constrain either rectangle tool to a square, hold down Shift be-
fore you begin dragging. 

See also “Tool Palette,” “Rectangle Tools,” and “Drawing Shapes.”

Oval Tools

You use the oval tools to draw filled and outlined ovals. The filled 
oval tool fills an oval with the current pattern, and the empty oval 
tool creates an outline using the current foreground color. 

To use the oval tools:

1. Select either the filled oval tool or the empty oval tool and position it 
in the canvas area.

2. Do one of the following:
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• For a filled oval, drag from one edge to another to create an 
oval filled with the current pattern.

• For an empty oval, drag from one edge to another to create 
an outline oval. The current foreground color creates a 1-
pixel outline. The width of the outline may not be changed.

3. To constrain either oval tool to a circle, hold down Shift before you 
begin dragging. 

See also “Tool Palette,” “Oval Tools,” and “Drawing Shapes.”

Pattern Tool

The pattern tool is used to select patterns. 

To select a pattern: 

1. Click and hold down the mouse button on the pattern tool to dis-
play the availalble patterns. 

2. Drag to the desired pattern; then releease the mouse button. 

3. Position the mouse pointer in the canvas area; then use one of the 
available pattern tools to add the pattern.

Patterns are based on the current foreground and background col-
ors. 

Figure 7.3 illustrates the pattern pop-up menu with the current pat-
tern outlined. In this case, it is the solid fill pattern in the top left cor-
ner of the pop-up menu.

Figure 7.3 The pattern pop-up menu

You cannot edit the default patterns available in Constructor.

See also “Tool Palette,” “Color Tool,” and “Setting Colors and Pat-
terns.”
Constructor for Palm OS CNP–93



Working with Icons & Bitmap Images
Using the Bitmap Editor Tools
Color Tool

The color tool lets you choose foreground and background colors. 
The topmost swatch is the foreground swatch, and the backmost 
swatch is the background color. 

Note that Palm OS resources support only 1-color (black and white) 
and 4-color (grayscale) bitmaps.

To select a foreground or background color:

1. Hold down the mouse button on either the foreground or back-
ground swatch to open a pop-up menu. 

2. Drag to the desired color and release the mouse button. 

The foreground and background color swatches (black and white or 
four shades of gray) available in the pop-up menu depend on the 
type of resource you are editing and the setting in the Colors menu.

For example, if the B&W swatch is selected in the editor window, 
only the Black & White command is available from the Colors 
menu; if the Color swatch is selected, the Colors menu lets you se-
lect from Black & White or Four Greys.

Tip for Macintosh: You can also set the foreground color to match 
an existing pixel by clicking a pixel with the dropper tool, or Op-
tion-clicking a pixel at any time. Set the background color by Shift-
clicking a pixel with the dropper tool, or Shift-Option-clicking a 
pixel at any time.

Tip for Windows: You can also set the foreground color to match 
an existing pixel by clicking a pixel with the dropper tool, or Alt-
clicking a pixel at any time. Set the background color by Shift-
clicking a pixel with the dropper tool, or Shift-Alt-clicking a pixel 
at any time.

See also “Tool Palette,” “Dropper Tool,” “Setting Colors and Pat-
terns,” and “Setting Colors and Patterns.”
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Editing Icons & Bitmaps
Editing a bitmap using Constructor is simple task. In general, you 
select a tool from the tool palette, move it onto the canvas area, and 
begin modifying the image. Operations may be performed in any 
order, on any pixel, at any time, and may be undone or redone 
using the Edit > Undo and Edit > Redo commands. 

However, some functions require additional explanation, which are 
included here for your convenience. These topics include: 

• Selecting Pixels Choosing a part of the bitmap image.

• Nudging Pixels Moving selected pixels a pixel at a time. 

• Copying Pixels Copying a selection. 

• Rotating and Inverting Pixels Manipulating selections.

• Setting Colors and Patterns Painting parts of a bitmap.

• Drag and Drop Using drag and drop effectively. 

• Drawing Shapes Tips on applying basic shapes to an image. 

• Setting Colors and Patterns Tips for specifying color and pat-
terns for drawing. 

Selecting Pixels

You can select pixels in a number of ways; use the method that best 
suits the operation you want to perform. 

To select pixels: 

Do any of the following:

• Use the Lasso Tool to select irregularly shaped areas. 

• Double-click the Lasso Tool to select the outermost outline of 
non-background-color pixels on the canvas. 

• Use the Marquee Tool to select rectangular shapes. Use the 
Shift key to constrain the selection marquee to a square. Dou-
ble-click the Lasso Tool to select the entire bitmap. (Macin-
tosh only). 

• Choose Edit > Select All everything in the canvas area. 
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Nudging Pixels

You can nudge a selection to move it one pixel at a time, which may 
provide more precise placement than dragging the selection with 
the mouse. 

To nudge a selection:

1. Select the pixels you want to move.

2. Use the arrow keys to move the selection in the desired direction. 
Each time you press an arrow key, the selection moves one pixel in 
the direction of the arrow key you press. 

Copying Pixels

You can copy pixels in two different ways: using the Edit > Copy 
command, or using a keyboard shortcut. 

To copy using a keyboard shortcut: 

• On the Macintosh, hold down Option and drag the selection. 
Be sure to press Option before you begin dragging.

• In Windows, hold down Alt and drag the selection. Be sure 
to press Option before you being dragging. 

Rotating and Inverting Pixels

When a bitmap editor window is active, the Options menu provides 
commands that let you flip and invert a selection. 

The Flip Vertical command flips a selection vertically (up and 
down). 

The Flip Horizontal command flips a selection horizontally (left to 
right). 

The Invert Pixels command inverts the pixels in a selection. 

Setting Colors and Patterns

There are three ways to set foreground and background colors. 
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For the Macintosh:

To set the foreground color, do one of the following:

• Choose a color from the foreground Color Tool swatch in the 
editor window.

• Click a pixel with the Dropper Tool.

• When any tool other than the dropper tool is active, Option-
click a pixel (Option selects the dropper tool from the key-
board when another tool is active.) 

To set the background color, do one of the following: 

• Choose a color from the background Color Tool swatch in the 
editor window.

• Shift-Click a pixel with the Dropper Tool.

• When any tool other than the dropper tool is active, Shift-Op-
tion-click a pixel. (Option selects the dropper tool from the 
keyboard when another tool is active.) 

For Windows:

To set the foreground color, do one of the following:

• Choose a color from the foreground Color Tool swatch in the 
editor window.

• Click a pixel with the Dropper Tool.

To set the background color, do one of the following:

• Choose a color from the background Color Tool swatch in the 
editor window.

• Select the Dropper Tool, then Shift-click a pixel

In addition, you can use Colors > Font command to set the fore-
ground and background colors to black and white, respectively. 

The Colors > Swap Fore& Back Colors command reverses the cur-
rent foreground and background colors. 

Any change in either foreground or background color affects the 
colors in the current pattern. By selectively choosing colors, pat-
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terns, and transparency, you can quickly create complex effects such 
as grid lines, slashes, and interesting color blends.

Drawing Shapes

To draw filled and outlined shapes, use the filled and outlined 
shape tools. For information about how to draw shapes, see Oval 
Tools and Rectangle Tools.

You can constrain the shape with the Shift key. You may press or re-
lease the Shift key at any time while drawing the shape. While the 
Shift key is pressed, the rectangle tools draw squares and the oval 
tools draw circles. 

Tip: To create a shape that is both filled and outlined, draw an 
outlined shape; then use the Paint Bucket Tool to fill the shape 
with the pattern. 

Drag and Drop

The bitmap editor has powerful drag and drop features, especially 
for Viewing Sample Views. Although you cannot edit the Viewing 
Sample Views directly, they are fully available for drag and drop.

Tips for using drag and drop: 

Create an 8-bit icon in large and small sizes; then drag the samples 
to the corresponding 4-bit, black and white, and mask samples to 
create an entire icon family. 

Note that this method is also useful for other kinds of resources, 
such as color cursors. You can even drag a large icon into a small 
icon sample view, although scaling generally doesn’t generate pre-
cisely scaled replicas.

For Macintosh When editing a bitmap, you can make an instant 
backup to save work in progress. Simply drag the sample to the 
desktop, or to any folder. If you later decide you want to revert to a 
previous stage of development, drag your saved work from the 
desktop back into the sample view.
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If you have a favorite bitmap that you want to use as a basis for fur-
ther work, use Constructor to open the source file that contains the 
original bitmap resource. Then you can simply drag the original bit-
map into your own Constructor project, and you’re on your way.
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Constructor for Palm 
OS Menu Reference
This chapter provides a description of each menu item in Construc-
tor. 

Constructor Menu Reference Overview
The Constructor menus include:

• File

• Edit

• Window

• Arrange

• Layout

• Options

• Colors

• Font

• Style

menus appear based on the appear depending on which windows 
are active and what you are working on in Constructor

File
Use the File menu commands for managing Constructor project 
files. 

New Project File

Creates a new Constructor project file.
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See “Constructor Project Files”.

Open Project File

Opens an existing Constructor project file.

See “Constructor Project Files”.

Close

Closes the active window. If you close the project window and there 
are unsaved changes, you are prompted to save before closing. 

This item is enabled when there is a window open.

See “Constructor Project Files”.

Save

Saves the active project file and, if the source code generation option 
is selected, generates and saves an interface source code file for the 
project. If the project hasn’t been saved yet, this command displays 
the standard file dialog box so you can specify a location for the file. 

This item is enabled when there is a project open that has been 
changed without being saved.

See also “Generate Source Code,” “Constructor Project Files,” and 
“Source Code Generation.”

Save As

Saves a project file using a new name, which may be saved in the 
same or another location. 

This item is enabled when there is a project open.

See “Constructor Project Files”.
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Generate Source Code

Generates and saves an interface source code file for the project. Use 
this command to generate and save the interface file without having 
to save the project file.

See also “Save” and “Source Code Generation.”

Page Setup

Displays the standard dialog box for choosing page setup options 
such as paper size and page orientation.

Print

Prints the active Constructor window.

This item is enabled when there is a document open.

Quit (Macintosh)

Quits Constructor. If any open files have not been saved, 
you are prompted to save before quitting the application. 

Exit (Windows)

Quits Constructor. If any open files have not been saved, you are 
prompted to save before quitting the application.

Edit
In addition to standard Edit menu commands, such as Copy and 
Paste, the Constructor Edit menu contains commands that let you 
create and modify resources, panes, menus, and so forth.

In addition, many Edit commands append a word to the basic com-
mand that reflects what you’re currently working with, for example 
resource, pane, or menu. In some cases, there may be two or more 
types of items listed. For example, when editing a menu resource, 
the Edit menu displays three commands to create new items related 
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to menus, including New Menu, New Menu Item, and New Separa-
tor Item.

Undo/Redo

The Undo/Redo description varies based on your last action. You 
can toggle between undoing and redoing an action by selecting 
Undo or Redo. Constructor provides a single-level undo. 

Cut

Removes a selection to the Clipboard. 

Copy

Copies a selection to the Clipboard. 

Paste

Pastes a copy of the Clipboard’s contents into the active window. 

Clear

Clears a selection from the active window. 

Select All

Selects all items in the active window.

Duplicate

Makes a duplicate of the selected items in the active window.

New Item

Creates a new item. The menu text reflects the nature of the item. It 
may be a resource, a menu, a menu item, and so forth.

New Separator Item

Inserts a menu separator; available only when editing menus.
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Remove Menu

Removes a menu from the menu bar without deleting the menu re-
source from the project. This item is only available when editing a 
menu bar. 

Edit Resource

The Edit Resource command opens a resource editor window, for 
example, the view editor, the menu editor, the text traits editor, and 
so forth.

When an editor is already open and an item is selected in the editor 
(such as a menu item), selecting this command opens the property 
inspector window for the selected item.

Window
The Window menu contains commands that display or activate var-
ious Constructor windows. Menu items are displayed as appropri-
ate. 

Property Inspector

Displays or activates the Property Inspector window for a related 
resource. Click the close box to close the Property Inspector win-
dow.

Catalog

Displays or activates the Catalog window. Click the close box to 
close the Catalog window. 

Alignment Palette

Display or activate the alignment palette. Click the close box to close 
the Alignment Palette. 
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Zoom Window

Zooms the active window, has the same effect as clicking the win-
dow’s zoom box.

Arrange
The Arrange menu is available when a form layout window is ac-
tive. This menu provides tools for aligning and distributing items in 
the form.

Arrange Objects

Opens the Arrange Objects dialog box.

Align Left Edges

Aligns selected items along the left of the leftmost selected item.

Align Horizontal Centers

Aligns selected panes halfway between the left of the leftmost se-
lected item and the right of the rightmost selected item.

Align Right Edges

Aligns selected items along the right of the rightmost selected item.

Spread Horizontally

Distributes selected items evenly from the left of the leftmost se-
lected item to the right of the rightmost selected item. 

Spread Vertically

Distributes selected items evenly from the top of the topmost se-
lected item to the bottom of the bottommost selected item. 
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Spread Vertically in Container

Distributes selected items from the top edge to the bottom edge of 
the container that holds all the items. 

Make Object Group

Assigns the same value to the group ID field of the selected user in-
terface items in a form.

Use this command when to assemble push buttons into a group so 
that only one push button may be selected at a time within the 
group. For more information on push buttons, see Table 3.1.

You may also assign a group ID to a user interface item by changing 
the group ID field in the item’s Property Inspector Window.

A group ID value of 0 means that the user interface item is not in a 
group.

Layout
The Layout menu is available when a form layout window is active. 
Items in this menu control the layout grid, and item visibility. Most 
items in the menu are enabled at all times.

Show Grid/Hide Grid

Displays or hides a dotted rectangular grid, respectively.

Snap to Grid/Don't Snap to Grid

Snaps an object to the nearest grid line when the mouse button is re-
leased. The Don’t Snap to Grid command lets you move objects 
without snapping them to the grid. 

Edit Grid

Lets you edit the size of the grid, in pixels. 
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Show Object IDs/Hide Object IDs

Displays or hides user interface item resource IDs in the Layout Ap-
pearance section of the form, respectively

Show Object Edges/Hide Object Edges

Displays or hides the edges of panes that are otherwise invisible. 
Displaying edges shows the size of unboxed items, making it easier 
adjust and avoid overlaps. 

Show Invisible Objects/Hide Invisible Objects

Displays or hides items that have the Usable checkbox deselected, 
respectively. 

Show Object Hierarchy

Opens the Hierarchy for Form window if it is not already displayed. 
Displays the hierarchy of objects and object types. To close the Hier-
archy window, click the window’s close box. This command is dis-
abled if the Hierarchy window is open and active.

Options
The Options menu is available when a bitmap editor is active. Most 
items in the menu are enabled when pixels are selected in the editor.

Flip Vertical

Turns the selected pixels upside down (rotates the selection 180°).

Flip Horizontal

Swaps selected pixels left and right. This command creates a mirror 
image of the pixels.

Invert Pixels

Makes white pixels black and black pixels white; available only 
when a selection is active. 
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Delete Image

This command is available to Palm OS® software icons and bitmap 
images. 

Set Image Size

Lets you set the image size, in pixels. 

Colors
The Colors menu is available when the bitmap editor is active. 

Four Grays (2-bit color)

Sets the color swatch pop-up to 4 shades of gray. Available only 
when the Color swatch is selected in the bitmap editor window. 

Black & White

Set the foreground color to black and the background color to white.

Swap Fore & Back Colors

Set the foreground color to the current background color and vice 
versa. 

Font
The Font menu is available when the bitmap editor is active. The 
font menu lists all available fonts on your computer. 

Style
The Style menu is available when the bitmap editor is active and 
contains commands to control text style, justification, and font size. 
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U
undo in Constructor 34
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using Constructor with 18
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W
Window menu, Constructor 105
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